Opened 2 years ago

Closed 3 months ago

#169 closed defect (worksforme)

Incorrect order of generic struct constructor params

Reported by: Thierry Delisle Owned by:
Priority: major Component: cfa-cc
Version: 1.0 Keywords: BoxPass
Cc:

Description

This code does not initialize the vector properly on the machines BrokkN.

I haven't yet confirmed if this is global or not.

#include <fstream.hfa>
#include <vector.hfa>
int main() {
        vector( int ) iv;
}

The call to the constructor must pass the size/alignment of int and allocator_t. In the given code, the order of arguments does not match the order of parameters.

Change History (1)

comment:1 Changed 3 months ago by Thierry Delisle

Resolution: worksforme
Status: newclosed

Works for me on the brokkN machines and my local machine.

Note: See TracTickets for help on using tickets.