Opened 4 years ago

Closed 4 years ago

#32 closed defect (fixed)

assert.h fails to compile in non __STRICT_ANSI__ mode

Reported by: Thierry Delisle Owned by: Rob Schluntz <rschlunt@…>
Priority: major Component: cfa-cc
Version: 1.0 Keywords:
Cc:

Description

The following code fails to compile :

extern void foo();

void libFloor() { 
	({
		if( 1 == 0 )
			; 
		else 
			foo(); 
	});
}

This code is equivalent to what can be in assert.h

Change History (2)

comment:1 Changed 4 years ago by pabuhr

The problem is the gcc lambda expression ({...}). It works if the lambda expression is commented out.

comment:2 Changed 4 years ago by Rob Schluntz <rschlunt@…>

Owner: set to Rob Schluntz <rschlunt@…>
Resolution: fixed
Status: newclosed

In 07516b56:

Set result type of statement expressions to void when body is empty or last statement is untyped [fixes #32]

Note: See TracTickets for help on using tickets.