#151 closed defect (fixed)

Input crashes CC1

Reported by: Thierry Delisle Owned by: pabuhr
Priority: major Component: cfa-cc
Version: 1.0 Keywords:
Cc:

Description

The following input crashes CC1

enum {
	A = (64 - sizeof(size_t)) / sizeof(unsigned long long),
	B = A * 8 * sizeof(unsigned long long)
};

struct C {
	size_t count;
	unsigned long long mask[ A ];
};

result :

CFA Version 1.0.0 (debug)
CC1 Translator error: stage 2, child failed 8

Change History (1)

comment:1 Changed 16 months ago by pabuhr

Resolution: fixed
Status: assignedclosed

Fixed specific bug with CC1 Translator error raising division by zero with no handler.

However, the division by zero is caused by bad expression evauation, which I am looking at.

Note: See TracTickets for help on using tickets.